Browser Security Requirements

At Central Bank we value your privacy and the security of your banking transactions. Therefore, we have implemented higher browser security standards:

  • SSL (Secure Sockets Layer) Version 3.0
  • 128-bit encryption

If your browser does not meet these security requirements, you will not be able to utilize our Online Banking or Online Bill Payment Services.

The following will show you how to check and/or change your browser settings to reflect this security upgrade:

Microsoft Internet Explorer

To set your browser encryption rate:

  1. Open Internet Explorer.

  2. Open the Help menu on the toolbar and click About Internet Explorer.

  3. Cipher strength (encryption rate) is listed in the About Internet Explorer window. If the cipher strength is less than 128 bit, update your browser at http://www.microsoft.com/windows/ie/downloads/default.mspx.

To set your browser SSL version:

  1. Open Internet Explorer.

  2. Open the Tools menu on the toolbar and click Internet Options.

  3. Click the Advanced tab.

  4. Scroll to the bottom of the window.

  5. Select the following options:

    • Use SSL 2.0

    • Use SSL 3.0

    • Use TLS 1.0

  6. Click OK.

Mozilla Firefox

To set your browser encryption rate:

  1. Open Mozilla Firefox browser.

  2. Open the Help menu on the toolbar and click About Mozilla Firefox.

  3. Verify that you have version 1.0 or later. If you have a version prior to 1.0, upgrade your browser at http://www.mozilla.org/en-US/firefox/fx/.

To set your browser SSL version,

  1. Open Mozilla Firefox.

  2. Open the Tools menu on the toolbar and click Options.

  3. Click Advanced.

  4. On the Advanced panel, scroll to the Security section. (If no subcategories are visible, click the plus sign Plus Signto expand the list.)

  5. Select the following options:

    • Use SSL 2.0

    • Use SSL 3.0

    • Use TLS 1.0

  6. Click OK.

Netscape Navigator or Communicator (Versions before 8.0)

To set your browser encryption rate:

  1. Open Netscape Navigator or Communicator.

  2. Open the Help menu on the toolbar and click About Navigator (or About Communicator).

  3. In the window that is displayed, locate the RSA security section. If this section reads, "This version supports U.S. security," the browser supports 128-bit encryption. If the section indicates you have an export version, the browser supports only 40-bit encryption. (Further details are also available by clicking Security on the Navigator toolbar.)

  4. If your cipher strength (encryption rate) is less than 128 bit, update your browser at http://browser.netscape.com/ns8/download/default.jsp.

To set your browser SSL version;

  1. Open Netscape Navigator or Communicator.

  2. Open the Edit menu on the toolbar and click Preferences.

  3. Click Privacy & Security.

  4. Click SSL.

  5. Select the following options:

    • Use SSL 2.0

    • Use SSL 3.0

    • Use TLS 1.0

  6. Click Okay.

Also set browser encryption rates at the SSL screen as follows:

  1. Click the Edit Ciphers button on the upper-right side of the SSL screen.

  2. Select all options beginning with either 128-bit or 168-bit.

Netscape Version 8.0

Netscape Version 8.0 has 128-bit encryption. You do not need to update this setting.

To set your browser SSL version:

  1. Open Netscape.

  2. Open the Tools menu on the toolbar and click Options.

  3. Click Advanced.

  4. On the Advanced panel, scroll to the Security section. (If no subcategories are visible, click the plus sign Plus Signto expand the list.)

  5. Select the following options:

    • Use SSL 2.0

    • Use SSL 3.0

    • Use TLS 1.0

  6. Click OK.

Recommended Browser Levels for Personal Online Banking:

Windows Vista & Windows XP

  • Microsoft Internet Explorer: 7.0 or higher
  • Firefox: 2.0 or higher
  • Opera: 8.0 or higher

Mac OS X 10.3 or higher

  • Firefox 2.0 or higher
  • Safari: 2.0 or higher
  • Camino 1.5.3 or higher
  • Opera: 8.0 or higher

Recommended Browser Levels for Business Online Banking:

Windows (98, ME, 2000 & XP)

  • Microsoft IE: 6.0 or higher
  • Mozilla Firefox: 1.0 or higher

Mac OS X

  • Mozilla Firefox: 1.0 or higher

Note:

Business Online Banking / Premier ACH is only qualified for use with Microsoft Internet Explorer on Windows PC's.